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1.  Introduction
The PalmEFIS product suite is a set of sophisticated tools that takes the technologies of glass
cockpits and makes it available to all pilots on a business tool that they may already own, the
PDA running the PalmOS. A PDA makes an excellent platform because of its good screen size,
easy to use user interface and low cost as compared to many GPS platforms. The PDA touch
screen and graffiti user interactions are faster and easier then the twist knobs and buttons of the
average GPS unit. Added to that the PDA is a powerful computer capable of driving artificial
horizons, moving maps, flight planning, and many more flight assisting capabilities.

An important factor that is often overlooked when considering new aircraft instrumentation is its
reliance on existing aircraft systems. One of the greatest features of PalmEFIS is that it is totally
independent of all the aircraft’s systems. So as the aircraft systems fail, PalmEFIS is there as a
reliable backup.
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2.  Product Overview
The PalmEFIS Product set is a collection of products that uses a pluggable architecture to
seamlessly integrate an ever-expanding functionality while protecting your initial investment.
The seamlessly integration is more then skin-deep, behind the scenes there is information
sharing between the products to make them all the more intelligent as products of the suite
are added. PalmEFIS suite of products consists of the following products and add-ons:

• PalmEFIS Attitude Indicator
• PalmEFIS Moving Map
• PalmEFIS Windometer
• PalmEFIS Flight Director (Add-on)
• PalmEFIS Flight Planning (Add-on)

The PalmEFIS Add-ons are matched with a PalmEFIS product to provide expanded its
functionality. For example matching PalmEFIS with the PalmEFIS Flight Director provides
PalmEFIS with navigational capabilities.

PalmEFIS Attitude Indicator

PalmEFIS Attitude Indicator adds the redundancy to your cockpit that you have always
wanted. Sure the backup attitude indicator is nice, but when they no longer match which one
is failing? With the PalmEFIS Attitude Indicator a quick glance gives
you the two-out-of-three vote to identify the failing instrument with
confidence. In the unlikely event that the complete panel fails PalmEFIS
Attitude Indicator is there to give you one more chance. With its isolated
systems it will be the last instrument standing. PalmEFIS uses a heads-up
styled display where the Attitude Indicator as its primary view.
Surrounding the Attitude Indicator is the airspeed indicator compass and
altimeter. Overlaid onto the Attitude Indicator view is an arrow showing the wind direction
and speed, and the resulting head and cross wind components. The wind is detected by
monitoring the effects it has on the aircraft’s flight profile. The PalmEFIS Attitude Indicator
view is configurable to match your aircraft specifications.

PalmEFIS Moving Map

PalmEFIS Moving Map uses a map view within the heads-up styled display.  Where the
airspeed indicator, compass, and altimeter tell you how fast you are going, which direction
and how high, the map tells you where you are located. The map contains
airports, navaids and airspaces layered on top of geographical elevation
contours. Overlaid on top of the map is the flight plan information that
shows you where you are in relation to where you want to go. All the
airports and navaids that you fly over have popup airport information that
gives you their communications frequencies, runway layout diagrams,
supported services and various remarks. To build flight plans PalmEFIS
Moving Map includes a full featured flight plan editor. When you need to get to an airport
fast pressing the PalmEFIS Moving Map Nearest Airport button directs you to the nearest
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airport, tells you how far away it is and how long it will take you to get there. The PalmEFIS
Moving Map is configurable to match your aircraft specifications or pilot preferences.

PalmEFIS Terrain Clearance

PalmEFIS Terrain Clearance shows the pilot the perspective of the surrounding terrain with
respect to their altitude. With this view the terrain that would conflict with
their aircraft is painted red and the terrain one thousand feet below their
altitude as a cautionary yellow. As the aircraft raises above the cautionary
ground clearances the terrain’s surface contours are revealed. Continuously
displayed on the Terrain Clearance view are the airports and airspaces for
the region. Flight plans that are built with the PalmEFIS Flight Plan editor
can be activated and navigated with respect to the surrounding terrain
elevations.

PalmEFIS Windometer

PalmEFIS Windometer focuses on a wind relationship view within the
heads-up styled display.  Here an image of an aircraft has the wind
detection and speed overlaid on top of it in the relationship of how the
wind is effecting it. The wind speed and direction is automatically
determined by monitoring the effect that the wind is having on the
aircraft’s flight profile. The PalmEFIS Windometer view is configurable to
match your aircraft specifications.

PalmEFIS Flight Director (Add-on)

The Flight Director overlays flight plan information on top of PalmEFIS, PalmEFIS Moving
Map, and PalmEFIS Windometer. The Flight Director supports automatic
flight plan leg selection and automatic To/From fix determination within a
flight plan leg. This allows the Flight Director to intelligently sequence
you through a flight plan in a forward or reverse direction without pilot
intervention. Along the way the Flight Director displays the To/From fix
identifiers, and the distance and ETE to the fixes. Popup airport
information is available on the To/From fixes giving you instant access to
communications frequencies, runway layout diagrams, services and airport remarks. Incase
of an emergency the nearest airport is a button push away.

PalmEFIS Flight Planning (Add-on)

PalmEFIS Flight Planning is a full featured flight plan editor. It builds flight plans from an
airport and navaid database so that the minimum amount of information needs to be entered.
If necessary custom waypoints are definable for the flight plan. Distance,
time and fuel usage is calculated for each leg and is summed. The total
fuel usage is compared against available fuel. Since the Flight Plan Editor
knows your aircraft performance specifications “What-if” analysis is
available by adjusting the flight plan leg altitudes and percent power to see
the changes in ETE and fuel usage. This helps insure that there will be
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enough fuel onboard for the trip.

PalmEFIS Datasets

The PalmEFIS Datasets provide the information that is used by the PalmEFIS Moving Map,
Flight Director and Flight Planning. Contained within the datasets are the airport and navaid
information, airspace information and the mapping topographical data. This means that you
are not required to build your own maps or to pay the expanses of joining another online
service to get your mapping and flight planning data chunks. Up to date information and high
quality/high resolution maps are available for immediate use. Because the dataset are prebuilt
for the PalmEFIS Suite to provide information on very large geographical areas. This means
that you are not required to download new datasets for new flight plans, all that you need will
need is most likely be already on your Palm.
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3. PalmEFIS Product and Feature Summary

PalmEFIS Attitude Indicator
• Attitude Indicator
• Aircraft Speed  (ground speed, true air speed, indicated air speed)
• Compass  (true course or track, magnetic heading)
• Altimeter (true altitude, density altitude)
• Wind Direction and Speed Detection
• Head Wind and Cross Wind Components
• Speed, Heading and Altitude Bugs

PalmEFIS Moving Map
• North-up Map
• Zoomable (120 miles to less then a mile)
• Eight direction scrolling
• Airport Symbols and Runway Layouts
• Airport Information
• Flight Planning
• Rubberbanding  Flight Plan Legs
• Distance, Heading and ETE to Flight Plan Fixes
• Nearest Airport
• Includes PalmEFIS Flight Director
• Includes PalmEFIS Flight Planning

PalmEFIS Windometer
• Aircraft Speed  (ground speed, true air speed, indicated air speed)
• Compass  (true course or track, magnetic heading)
• Altimeter (true altitude, density altitude)
• Wind Direction detection
• Head Wind and Cross Wind Components
• Speed, Heading and Altitude Bugs.

PalmEFIS Flight Director
• Airport Information
• Flying the Arrow to Fixes (PalmEFIS Attitude Indicator and Windometer)
• Rubberbanding Flight Plan Legs (Moving Map)
• Automatic Flight Plan traversal
• Intelligent To/From Flight Plan Fix Selection
• Distance, Heading and ETE to Flight Plan Fixes
• Direct To Flight Plan Fixes



PalmEFIS User Manual Feature Summary

Hangar B-17, Inc. Page 7
www.HangarB17.com

• Nearest Airport
• Safe Gliding Determination to Nearest Airport

PalmEFIS Flight Planning
• Full Flight Plan Editing
• Airport and Navaid database
• Heading, Distance, ETE, and Fuel Usage Calculations
• Distance, Time, and Fuel Usage Totals
• Remaining Fuel
• Taxi Fuel Burns
• Fix Identifier and Partial Name Lookups
• Altitude and Percent Power What-If Analysis
• Uses Detected Wind Conditions

PalmEFIS Datasets
• Airport Information

� Name
� Identifier
� Type
� Altitude
� Runway layout diagrams
� Communications Frequencies
� Services
� Remarks

• Navaid Information
� Name
� Identifier
� Type
� Altitude
� Communications Frequencies

• Airspace Information
� Controlling authority
� Type
� Minimum altitude
� Maximum altitude
� Shape

• Topographical data.
� Location
� Elevation
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4. Requirements
This section describes the hardware, software and interdependencies of the PalmEFIS
products.

Hardware and Operating System
The PalmEFIS products run on a wide range of PalmOS PDA devices and virtually all GPS
receivers that are capable of providing a data feed. PalmEFIS provides a demonstration mode
that allows you to try it on your PDA before a purchase. If you do not own a PDA or GPS, or
are looking to upgrade here is a set of guidelines for your purchase.

The Minimum PalmEFIS Requirements:

• PalmEFIS runs on any PalmOS compatible PDA with the PalmOS version of 3.5 or
greater.

• CPU speed of at least 33 mhz.
• At least 8 megs of memory on the PDA.
• A Color PDA is optional but highly recommended.
• Any GPS that supports NMEA 0183 v2.0 RMC, GGA, and GSA sentences.

PalmEFIS Suite Add-on Matrix
The PalmEFIS product suite can be mixed and matched to provide the functionality that you
need. The PalmEFIS Suite Matrix shows the possible combinations and dataset requirements.

PalmEFIS PalmEFIS
Moving Map

PalmEFIS
Windometer

PalmEFIS
Flight Director

(add-on)

PalmEFIS
Flight Planning

(add-on) *3

PalmEFIS � � � �

PalmEFIS
Moving Map

� � Included Included

PalmEFIS
Terrain

Clearance

� � Included Included

PalmEFIS
Windometer

� � � �

PalmEFIS
Flight Director

(add-on)

� * 1 Included � Required

PalmEFIS
Flight Planning

(add-on) *3

� * 1 Included � * 2Required

PalmEFIS
Datasets

Required Required Required

* 1 Included in PalmEFIS Moving Map and Terrain Clearance.
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* 2 The PalmEFIS Flight Director requires the Flight Planning add-on.
* 3 The PalmEFIS Flight Planning is a free add-on.

All of the products of the PalmEFIS products are purchased separately unless otherwise
noted. When purchased each product adds additional functionality while seamlessly
integrating with prior PalmEFIS Suite purchases. Products within the PalmEFIS Suite do not
require the other products of the suite to function, with the exception of the add-ons. The
PalmEFIS Suite add-ons require at least one of the PalmEFIS Suite products to be fully
functional.

Registration Id
The PalmEFIS Suite runs in a demonstration mode until they are purchased. This allows you
to experience the full functionality with the exception of connecting it to a GPS to receive its
data feed. Once a PalmEFIS product is purchased you will be supplied with a Registration Id.
Entering the Registration Id into PalmEFIS turns on the GPS data feed.
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5. PalmEFIS Products Getting Started
The PalmEFIS Suite is pretty much ready to go as soon as it is installed on your PDA. When
PalmEFIS is first installed it runs in a demo mode. In the demo mode PalmEFIS simulates a
GPS data feed. In order for PalmEFIS to use the realtime GPS data the Registration Id must
be set. The Registration Id is issued when the PalmEFIS products are purchased. The other
things that you may want to do before using PalmEFIS is to set the display units and to
configure PalmEFIS for your GPS and aircraft.

To help you get all products in the PalmEFIS Suite up and going quickly we’ll walk you
through the steps necessary to get started. These include:

• PalmEFIS Installation
• Starting PalmEFIS
• Setting the Registration Id
• Configuring the GPS Connection
• Setting PalmEFIS Preferences
• Disable Palm Auto-Off
• Setting the Aircraft Information
• Setting the Aircraft Airspeed Specifications
• Setting the Aircraft Cruise Performance

PalmEFIS Installation
The primary use of HotSync operation is to synchronize your PDA with the information that
is on your desktop. But the HotSync operation is also used to install new software onto your
PDA. This is how PalmEFIS is installed on your PDA.

To install PalmEFIS first go to the www.HangarB17.com site
and download the program(s).

Locate the downloaded program(s), The Windows Explorer is
very useful for this. They will be in a zip file. Expand the zip file
into the directory that they were downloaded.

Select all the files that end with a “.prc” or “pdb” extension.
Using the mouse right-click on the selected files. A popup menu
will be displayed with “Open” as the first menu item. Select the
“Open” menu item.
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The selected “.prc” or “pdb” files are then opened into the Palm
Install Tool. They are now ready to be installed on your PDA
with a HotSync operation.

Pressing the HotSync button on the Palm cradle starts the
HotSync operation that will install the PalmEFIS software.

Starting PalmEFIS
PalmEFIS must first be installed on the Palm Handheld through a HotSync operation. By
default PalmEFIS will be put into the Palm Unfiled category.

To start or launch PalmEFIS go to the Unfiled category on
your Palm Handheld and tap on the PalmEFIS icon.

Setting the Registration Id
When PalmEFIS is downloaded it runs in a demonstration mode, which ignores GPS input
until the Registration Id is entered. After the Registration Id is entered PalmEFIS auto detects
the attached GPS unit and starts using its input to update the display. With each PalmEFIS
product purchase the Registration Id is augmented to reflect each product. Therefore only
enter the last Registration Id issued.

To set the Registration Id tap on the Palm dropdown menu
button in the Palm graffiti area after launching PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.
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The Options menu drop down will be displayed. Select the
About menu item.

The About dialog is displayed with the Reg Id entry field just
above the OK push button. In this field enter the PalmEFIS
registration id that you received with your purchase.

Configuring the GPS Connection
PalmEFIS will automatically connect to most GPS receivers and does not need configuring.
If your GPS receiver uses a serial port other than the Cradle/Cable port and its baud rate is
other then 4800 bps you will need the following setup.

The PalmEFIS Garmin and Bluetooth GPS drivers do not need to be configured. These GPS
drivers are self-configuring. Removing the prior PalmEFIS driver (peGpsDriverStd) and
HotSyncing the Garmin or Bluetooth GPS driver onto the PDA is all that is necessary.

To configure PalmEFIS to connect to a GPS receiver go to the
Palm System category. Launch the Prefs application by tapping
on its icon.

In the upper right corner of the Preferences dialog is a popup list
that is most likely displaying General. Tapping on the popup list
displays the available preference sections.
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Selecting the Connection popup list item from the popup list
accesses the Preference’s connections.

From the Preference’s Available Configurations list, select the
PalmEFIS to GPS configuration and press the Edit push button.

The connection Edit dialog is used to select a serial port which is
called a Connection Method. Using the Connection Method’s
popup list select another serial port, other than the default
Cradle/Cable port. This could be a port such as the CD port.

To change the port’s baud rate tap on the Details push button.
This displays the connection Details dialog.

The baud rate or connection Speed is changed by tapping on the
Speed popup list and selecting the baud rate that the GPS
receiver supports. Consult the GPS documentation to determine
the appropriate speed. The default speed is 4,800 bps.

Setting PalmEFIS Preferences
PalmEFIS supports customization of units and display settings.

Units can be changed for:

• distance

• altitude
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• speed

The different units are typically selected based on aircraft instrumentation or pilot
preferences.

Display preferences exposes flight calculator styled functionality for:

• speed

• heading

• altitude with their specific variations

For example speed could be displayed as indicated airspeed, true airspeed, or ground speed.

To change the PalmEFIS preferences tap on the Palm dropdown
menu button in the Palm graffiti area after starting PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Preferences menu
item.

The Preferences dialog will display once the Preferences menu
item is tapped. At the top of the dialog is the Units section. Here
Distance could be set to miles (mi), nautical miles (nm), or
kilometers (km) by tapping on the corresponding box. Altitude
has the option of displaying in feet (ft) or meters (m). Speed can
display in miles per hour (mph) or knots (kts). As in the distance
field, tapping on the corresponding button box sets the altitude
and speed units.

Disable Palm Auto-Off
Disabling the Palm auto-off feature allows PalmEFIS to continuously display results during a
flight. Otherwise the Palm will automatically shutoff after a period of inactivity. Yet before
the flight when preferences are being set or weather parameters are being entered it is
advantageous to have the Palm auto shutoff to conserve power. 

To disable the Palm auto-off capability, tap on the Palm
dropdown menu button in the Palm graffiti area after PalmEFIS
is launched.
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The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Preferences menu
item.

The Preferences dialog will display once the Preferences menu
item is tapped. At the bottom of the Preferences dialog is the
Disable Auto Off check box. Check the check box to keep your
Palm from turning off. Uncheck the check box to allow the Palm
to turn off after a period of inactivity.

Setting the Aircraft Information
PalmEFIS records various aircraft specifications to assist in customizing the display to match
your aircraft and as support for PalmEFIS add-on functionality such as PalmEFIS Flight
Planning and the Flight Director.

To change the PalmEFIS aircraft information tap on the Palm
dropdown menu button in the Palm graffiti area after launching
PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Aircraft menu
item.
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The Aircraft Information dialog will display once the Aircraft
menu item is tapped. In this dialog various aircraft specific detail
are entered. Enter the aircraft identification number in the Call
Sign field. The Crosswind (maximum crosswind), Glide Ratio,
Climb Rate, Ceiling (service ceiling), Takeoff (takeoff
distance), Landing (landing distance) and Taxi fuel
consumption fields are entered based on the aircraft
specifications listed in the aircraft handbook. The Usable (usable
fuel) should be entered based on the amount of fuel that is
onboard for a given flight.

Consult your Pilot’s Operating Manual to get these numbers. The
Glide Ratio may have to be determined experimentally if it is not
listed in the manual. If the glide ratio is not listed in the manual
climb your aircraft up to a safe altitude and then pull back the
power. Trim your aircraft to it best glide speed and record your
altitude and initial distance. After descending say 3 thousand feet
record the number of miles flown while gliding. Then apply the
following formula:

Glide Ratio = miles * 1000 / feet descended

For example:

Glide Ratio = 5 miles * 1000 / 2000 feet = 2.5

Enter 2.5 as the Glide Ratio.

Setting the Aircraft Airspeed Specifications
The PalmEFIS Airspeed Specifications dialog has the aircraft speeds that are used to
customize the PalmEFIS speed gage.

To change the PalmEFIS aircraft airspeed specifications tap on
the Palm dropdown menu button in the Palm graffiti area after
starting PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Airspeed Spec
menu item.
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The Airspeed Specification dialog will display once the
Airpseed Spec menu item is tapped. The information used to
enter into this dialog is listed in the aircraft handbook. The
airspeed values are cross-checked with each other so it is
important to have all the airspeed numbers handy before entering
them into the dialog fields. Some aircraft do not have flaps,
which means that they will not have a dirty stall speed (Vs2). In
this case set the Vs1 Clean field to 0.

Consult your Pilot’s Operating Manual to get these numbers.

Setting the Aircraft Cruise Performance
The PalmEFIS Cruise Performance dialog captures the aircraft cruise specifications that are
used during flight planning. PalmEFIS requires a minimum subset of the cruise information
to be entered for it to interpolate the rest of the performance chart.

To change the PalmEFIS cruise performance information tap on
the Palm dropdown menu button in the Palm graffiti area after
starting PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Cruise Perf menu
item.

The Cruise Performance dialog will display once the Cruise
Perf menu item is tapped. Before entering values into the cruise
performance table notice that the table is broken into three
altitude ranges. The three altitude ranges that should be entered
into the table are the aircraft’s minimum altitude performance
specifications, the best performance altitude, and maximum
altitude performance specifications. For each altitude only enter
the highest and lowest Percent Power specifications.

If your aircraft has a variable pitch prop, select the rpm that
you typically use during normal cruise, and use the rpm’s
corresponding cruise performance specifications.

Consult your Pilot’s Operating Manual to get these numbers.





PalmEFIS User Manual PalmEFIS

Hangar B-17, Inc. Page 19
www.HangarB17.com

6. PalmEFIS Attitude Indicator
The PalmEFIS attitude Indicator utilizes the power of the Palm to produce flight and
navigation instrumentation in the same manner as a Heads Up Display that is a useful
backup, cross check, or convenience to pilots in their flight
experience. In some cases PalmEFIS gives the pilot an added
safety margin. With the cross wind and head wind components
pilots are alerted early to dangerous conditions so that they
could land to refuel if head winds are too strong or select
another airport it the cross winds exceed the aircraft capabilities
or the pilot's comfort level. With the PalmEFIS density altitude
feature pilots can cross check their aircraft’s altitude
performance margins visually in real-time. But one of the
biggest reasons for having PalmEFIS in your flight bag is on
those dark high overcast nights or flights in the clouds when the instrument panel goes dark.
Pointers no longer correspond to each other. Where the next communication would be "I’ve
lost all…" That’s when PalmEFIS gives you one more chance to return to earth safely.

Features
PalmEFIS has features similar to a Heads Up display with the addition of wind direction
and speed, and the effect that the wind has on the aircraft. As with most Heads Up displays
the aircraft speed is on the left edge of the display, the aircraft direction is on top, with the
current altitude displayed on the right edge. In the center is the aircraft attitude. The wind
effects are a composite on the aircraft attitude display. This will graphically display the wind
direction with respect to your aircraft direction along with the current wind speed. PalmEFIS
has the net effect of a flight computer that constantly updates itself based on the current flight
conditions.

Attitude Indicator

The Attitude Indicator is driven from a synthetic gyro. to show rate of climb and turn.

Aircraft Speed

The aircraft speed is configurable to display Ground Speed, True Airspeed, or Indicated
Airspeed. The speed could also be set to use knots or mph units.

Compass

The compass is configurable to show either the True Course or Magnetic Heading.

Altimeter

The altimeter displays True Altitude or uses the outside air temperature, atmospheric
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pressure and current altitude to determine and display the Density Altitude.

Wind Direction and Speed Detection

PalmEFIS can work with statically entered wind speeds and directions or it can automatically
determine the wind conditions from the wind effects on your flight profile.

Head Wind and Cross Wind Components

To assist a pilot with their landing or headwind decisions PalmEFIS breaks the wind
conditions into their head and crosswind components and displays them as an overlay on the
Attitude Indicator view.

Speed, Heading and Altitude Bugs

The aircraft speed indicator, compass and altimeter all support bugs to mark the targeted
speed, heading and altitude.

Setting Options
Setting the PalmEFIS options allows the pilot to configure it to their preferences or to use it
in the same way as a flight calculator. The PalmEFIS options are:

• Set Bugs
• Select True or Density Altitude
• Select Indicated or True Airspeed or Ground Speed
• Select Track, True Course or Magnetic Heading
• Setting the Current Temperature and Altimeter
• Set Wind Speed and Direction

Set Bugs
PalmEFIS has Bugs for targeted trip speed, heading and altitude. The bugs are displayed as
black triangles on the speed, heading and altitude scales in a position that represents the bug
value. The bugs will be displayed on the PalmEFIS Speed Indicator, Compass and Altimeter
gauges.

To set a speed, heading or altitude bug tap on the Palm
dropdown menu button in the Palm graffiti area after starting
PalmEFIS.

The Palm dropdown menu bar will appear with the View menu
highlighted. Select the Set Bugs menu item.
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When the Set Bugs menu item is selected, PalmEFIS displays
the Bugs dialog. Here the current heading, altitude and speed
bugs are displayed. To change a bug setting drag Palm stylist
over the value to change and then enter a new value in the Palm
graffiti area.

Select True or Density Altitude
PalmEFIS can display the altitude as true altitude or density altitude. When density altitude is
selected the Altimeter scale and current altitude value adjust to display the density altitude.
For the density altitude to display correctly the current temperature must be set on the
Weather dialog. After selecting true or density altitude the PalmEFIS status bar will display
“TA” (true altitude) or “DA” (density altitude) depending on what was selected.

To select density or indicated altitude for PalmEFIS to display,
after starting the PalmEFIS, tap on the Palm dropdown menu
button in the Palm graffiti area.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Preferences menu
item.

The Preferences dialog will display once the Preferences menu
item is tapped. The true altitude/density altitude selection is near
the bottom of the dialog in the Altitude field. To select indicated
altitude tap on the TA box. Density altitude is selected by
tapping the DA box.

Select Indicated or True Airspeed or Ground Speed

The GPS data feed supplies the ground speed of the aircraft. It is possible with variations in
heading while the indicated airspeed of the aircraft is held constant to determine the true
airspeed of the aircraft. When the current temperature is entered into PalmEFIS it can then
determine the aircraft’s indicated airspeed. As such PalmEFIS can display any of the speed
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modes depending on pilot preferences or as a crosscheck of aircraft instrumentation. When
the pilot selects a ground speed, true airspeed or indicated airspeed, the speed mode is
displayed on the PalmEFIS status bar as the corresponding GS, TAS, or IAS.

To select indicated airspeed, true airspeed or ground speed for
PalmEFIS to display, tap on the Palm dropdown menu button in
the Palm graffiti area after launching PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Preferences menu
item.

The Preferences dialog is displayed when the Preferences menu
item is tapped. Find the Speed field in the Display section of the
dialog. Indicated Airspeed is selected by tapping on the IAS
box. To select True Airspeed tap the TAS box. Ground Speed
is selected by tapping on the GS box.

Select Magnetic Heading, True Course or Track

PalmEFIS can display the heading information with or without the magnetic variance for the
current location. The heading without the magnetic information is the true course as opposed
to using the magnetic variation to get the magnetic heading. The current heading mode is
displayed on the PalmEFIS status bar as TC for true course, MH for magnetic heading or
TRK for track.

To select magnetic or true course heading for PalmEFIS to
display, tap on the Palm dropdown menu button in the Palm
graffiti area after launching PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.
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The Options menu will drop down. Select the Preferences menu
item.

The Preferences dialog is displayed when the Preferences menu
item is tapped. In the Display section of the dialog is the
Heading field. The Heading field could be set to magnetic
heading (MH), true course (TC), or Track (TRK). Tapping on
the corresponding box sets the heading mode. The selected box
is shaded to show the selection.

Setting the Current Temperature and Altimeter

The current temperature and Altimeter values are used for density altitude and indicated
airspeed determination. The current temperature must be set before PalmEFIS can display
the density altitude or the indicated airspeed accurately.

To set the current temperature or altimeter values, tap on the
Palm dropdown menu button in the Palm graffiti area after
launching PalmEFIS.

With the View menu displayed select the Weather menu item.

Enter the current temperature in the Temperature field. The
temperature could be either Celsius or Fahrenheit. Set the
temperature units in the popup list at the end of the Temperature
field according to the units of the temperature value entered by
tapping on the down triangle and selecting C (Celsius) or F
(Fahrenheit).

Enter the current altimeter setting in the Altimeter field.
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Set Wind Speed and Direction

PalmEFIS supports automatic wind speed and direction detection or pilot entered wind speed
and direction. With the wind detection set in the automatic mode PalmEFIS determines the
wind speed and direction when the aircraft changes direction with a course difference of at
least 20 degrees. A new wind speed and directions is calculated after three consecutive
course changes. During the automatic wind detection process the indicated airspeed must be
constant. The pilot can at any time over-ride automatic wind detection and designate a wind
speed and direction. This is useful during the initial portion of the flight where ATIS
information is available and the automatic wind detection has not gathered enough
information to accurately predict the wind conditions. 

To tell PalmEFIS to automatically detect wind speed and
direction or to manually enter it, tap on the Palm dropdown
menu button in the Palm graffiti area after launching PalmEFIS.

With the View menu displayed select the Weather menu item.

The Weather dialog will appear. For automatic wind detection
check the Automatic check box. To over-ride the automatic
wind detection uncheck the Automatic check box and enter a
wind direction in the Direction field and wind speed in the Speed
field.

Operations
The Inner-Works

The PalmEFIS Attitude indicator works by comparing the rate of heading and climb change.
It then takes the changes and applies several mathematical relationships to determine bank
and climb rate. Because PalmEFIS relies on rate changes from a GPS signal there is a
response time delay. This delay comes from the fact that a GPS receiver sends updates once a
second and in order to detect a rate change one or more data samples must be collected.
PalmEFIS uses artificial intelligence in the form of modified fuzzy logic to minimize the
delay effects. As such PalmEFIS can usually track within one to two seconds of actual
conditions. This has proved to be more than good enough to detect a failing instrument or
even control an aircraft if the ultimate instrument failure happens.

The PalmEFIS Wind Detection is determined by capturing the flight speed changes that
happen during a flight. The effects of power setting changes and climb/descent speeds
variations are filtered out to leave the effect caused by the wind. With the remaining wind
effects the wind speed and direction is determined. Three or more turns are necessary for
each wind sample where each turn must be greater then 25 degrees. The best wind detection
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results are seen when the airspeed is held constant and the turns are greater then 45 degrees.

Best Practices

The PalmEFIS Attitude indicator responds to a wide range of flight conditions. Standard rate
turns, steep turns along with the range of bank rate changes. It adjusts to quick jumps into
and out of turns, to follow the aircraft’s flight profile as close as possible. Yet it is possible to
fool the attitude indicator. For example if a bank is added and then removed in less then a
second PalmEFIS will most likely not notice it. Slow rolls without heading change will also
go unnoticed. Another flight condition that PalmEFIS misses is inverted flight. This means
that intentional aerobatics in the clouds is not recommended. Yet PalmEFIS can help you
recover from unintentional cloud based aerobatics. This is because it will accurately display
grave yard spirals in the same manner as a gyro driven attitude indicator with a steep bank
and high rate of descent. If you accidentally roll inverted in the clouds PalmEFIS will help
you achieve a stable wings level and level forward direction flight profile. At that point
gravity will take over and you know that you are upside down because you are hanging from
your seat beat and shoulder harness. Then it’s a matter of pushing the nose up 20 degrees,
neutralizing the elevator, and using the ailerons to roll the plane upright. Here PalmEFIS will
become effective once more as the aircraft comes upright as you slowly roll out of the aileron
roll and the subsequent turn that will happen as the aircraft roll rate slows down. The good
part is that PalmEFIS will help keep things straight and level by watching the PalmEFIS
attitude trends and making directional changes slowly and deliberately or fly the same as you
would for normal IFR flight. As always practice helps.

The Altimeter can display indicated or density altitudes. In the mountains in the summer
time it is useful to do a quick switch to density altitude to cross reference takeoff
performance before taking the active. While this may not get you to reach for the Pilot’s
Operating Manual, it may get you reaching for the mixture control to increase takeoff
performance.

The Compass displays a magnetic or true course heading. Both take into account magnetic
variation, but the magnetic heading also factors in the wind effects. The true course heading
is probably the more useful of the two, unless you only have a wet compass on board. The
PalmEFIS magnetic heading is a byproduct of the wind detection calculations. As such the
PalmEFIS magnetic heading and your wet compass may differ by a significant amount. This
is because at very slow speeds with moderate crosswinds the crab angle would have to be
quite large to maintain your current heading. If your wheels are still on the ground the odds
are that your aircraft is not crabbed. Therein arises the error between your compass and the
PalmEFIS headings. Letting the crab kick in after liftoff, PalmEFIS and your compass will
once more agree.

PalmEFIS can display Speed as ground speed, true airspeed or indicated airspeed. Of the
three the ground speed is the most useful unless your Pitot tube ices over. PalmEFIS gets the
ground speed directly from the GPS receiver, while the true airspeed and indicated airspeed
is a byproduct of the wind calculations.

The best PalmEFIS Wind Detection results are seen when the airspeed is held constant and
where three consecutive turns are performed with a heading change between 25 then 45
degrees for each turn. Normal cruising, regardless of being on a flight plan, typically yields
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good results. The best time to determine the wind conditions of a destination airport is during
the descent into the airport. Once the descent is stabilized make two shallow turns to each
side of the descent path followed by a turn back onto the descent path. If the altitude descent
range is large follow this procedure several times to capture several wind detection results.
This will give you a wind change profile that could tell you what to expect in the way of
wind shear and other wind gust effects.

Sequence Through PalmEFIS Views
PalmEFIS is built on an expandable platform. This allows new views or modules to be
integrated into PalmEFIS.

Pressing the Palm Schedule key cycles PalmEFIS through all
PalmEFIS add-on views that are installed on your Palm. For
example pressing the button could cycle the Attitude Indicator
view to the Moving Map view if both view are installed on your
Palm.



PalmEFIS User Manual PalmEFIS Moving Map

Hangar B-17, Inc. Page 27
www.HangarB17.com

7. PalmEFIS Moving Map and Terrain
Clearance
PalmEFIS Moving Map is a visual navigation tool that shows you where you are on a map
and guides you to where you want to go. The PalmEFIS Moving Map gives you the map
information that you need without the clutter. Airspaces are
clearly seen and airports stand out. Topographical contours
reveal the mountain pass that you are looking for. As you
approach your destination zoom in to see the airport’s runway
layout. Zoom in further and get runway identifiers. “Cleared to
land on 24R” is now a visual sequence because you can look
and see it, right there on the PalmEFIS Moving Map.

Popup airport information on the PalmEFIS Moving Map makes
unexpected diversions a non-event. No fumbling for the correct
sectional because the information is a tap away. You will now
find yourself monitoring airport traffic as you fly over. This is because PalmEFIS Moving
Map makes it so easy. No feature pollution, PalmEFIS Moving Map is simply the visual
navigation tool that you have always wanted.

PalmEFIS Terrain Clearance is a critical navigation tool for pilots that are traversing
mountainous regions. The Terrain Clearance view quickly
reveals the ground clearances that are in conflict with your
aircraft and warns you about ground clearances that are within a
cautionary range, day or night. Yet even while you are
negotiating mountain passes the PalmEFIS Terrain Clearance
view supplies the same airport, airspace and navigational
support that is available with the PalmEFIS Moving Map view.
The PalmEFIS Terrain Clearance maps are zoomable to reveal a
comfortable clearance view around your aircraft.

Popup airport information is available on the PalmEFIS Terrain Clearance view just as it is
on the PalmEFIS Moving Map.

Features
The PalmEFIS Moving Map builds runtime maps from a digital elevation topographical,
airspace, and airport datasets or layers. This allows you to selectively toggle each layer to
suit your preferences.

The PalmEFIS Terrain Clearance view shares many of the features with the PalmEFIS
Moving Map with one big exception, it displays the terrain elevations that are in conflict with
your aircraft or are within a cautionary ground clearance range.

Visual Terrain Clearance (PalmEFIS Terrain Clearance only)

The terrain map is constantly redrawn to display the elevations that are in conflict with your
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current altitude and which elevation clearances that are within the 1000 foot caution range.

Uses the PalmEFIS Datasets

The moving and terrain clearance maps are generated in realtime from PalmEFIS Datasets.
Because the maps are drawn from the datasets instead of bitmaps they are very accurate.
With the PalmEFIS Datasets the maps are ready to use without anything to build or
configure. The PalmEFIS Datasets are available from www.HangarB17.com.

North-up Map

The moving map is oriented so that north is always up. As your aircraft turns the aircraft
image on the map is rotated so that it has the same orientation as your aircraft has to true
north.

Zoomable

The PalmEFIS Moving Map supports zooms from 120 miles to less then a mile. Over the
zoom range map details are added from airspaces, to runways layouts, with varying levels of
identifiers and labels being shown.

Eight direction scrolling
PalmEFIS Moving Map configures the Palm hardware buttons to select and control eight
directional scrolling.

Airport Symbols and Runway Layouts

Depending on the zoom level PalmEFIS Moving Map draws either airport symbols or the
actual airport runway layout directly on the map.

Airport Information
The PalmEFIS Moving Map supports pickable airport information. Tapping on an airport
identifier pops up the Airport Information dialog. From the Airport information dialog
communication frequencies, runway layouts, services, and airport remarks are available.

Flight Planning

The PalmEFIS Flight Planning is used to create flight plans and the PalmEFIS Flight
Director works with the Moving Map to navigate them.

Rubberbanding Flight Plan Legs

The flight plan legs have a unique feature called rubberbanding flight plan legs. This means
that you never have to find your flight plan leg no matter how far you deviate from you flight
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plan. They stretch out to meet you where ever you are and lead you to the next fix.

Distance, Heading and ETE to Flight Plan Fixes
Along with showing where you are on a map, the PalmEFIS Moving Map also helps you
navigate flight plans. The active flight plan leg is drawn and the To/From fixes have their
identifiers, distance and ETE displayed in real-time.

Nearest Airport

Locating the nearest airport is only a button push away. Pushing the nearest airport button
finds the airport closest to your current location and then leads you too it.

Setup Options

Map Options and Legend

The PalmEFIS Moving Map and Terrain Clearance display maps in layers where they could
be turned on or off. The map layers are:

• The aircraft image.

• All airports.

• All navaids.

• Airspaces.

• Elevation contours.

Turning on or off each layer is controlled from the Map Options dialog.

The map elevation contour color legend is part of the Map Options dialog. Bringing up
dialog allows you to see which elevation range applies to each contour color.

To toggle the map layers tap on the Palm dropdown menu button
in the Palm graffiti area after PalmEFIS is launched.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the View menu item.
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With PalmOS 3.5 the Options menu will drop down. Select the
View menu item.

With PalmOS 3.5 the View Options popup list is displayed. A
tap on the Moving Map or Terrain Clearance list item causes
the Flight Plan Options to be displayed.

With PalmOS 4 and above the Options menu will drop down.
Select the Moving Map or Terrain Clearance menu item.

The Map Options or Terrain Clearance dialog is displayed.
Toggle on or off the checkbox for the map layer and press the
OK button for the map to be updated. Pressing the Cancel button
causes any option changes to be dropped. In this case the map
will not change.

Operations
The Inner-Works

The PalmEFIS Moving Map and Terrain Clearance view are tuned for the cockpit
environment. The mapping functionality is simplified as much as reasonable and then tied to
the Palm hardware buttons to minimize the effects of vibrations. The Palm touch screen is
only used for selecting airport information so that a vibrating fingertip is not mistaken for a
map scrolling command. On the ground dragging the Palm stylist across the map works great
for scrolling the map but this does not work in the air.

The map data is built to allow large geographical areas to be loaded onto the Palm. The map
data is divided into areas about the size of Sectional Charts so that you could load as much or
as little data that you need or as Palm memory space allows. The map data is generated from
US Department of Defense DAFIF databases and USGS 250k datasets.

Best Practices

Getting started with PalmEFIS Moving Map and Terrain Clearance is pretty much a load
and go operation. You can load the PalmEFIS Moving Map software and the map datasets
onto your Palm, connect your GPS and go flying. Once the euphoria dies down it is then time
to figure out how to create flight plans and activate them. But you could wait for that until
you are ready to go somewhere. That’s because the PalmEFIS Moving Map and Terrain
Clearance views are perfectly happy following you around the sky without flight plans.
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A fun trick when you are aimlessly exploring the skies is to press the Nearest Airport
button. While there are no sudden surprises, after canceling the Airport Information dialog a
leg will be drawn on the moving map to the nearest airport. As you fly around the nearest
airport is updated and changed to another airport when it becomes the closest.

The PalmEFIS Moving Map datasets are arranged and named the same as the USGS digital
elevation data patches. Each patch is about the size of a sectional map, except that is they are
arranged on a grid that does not overlap. Each dataset has the airport, airspace, and
topographical information for the area. The naming convention for each dataset forces
natural groupings to occur for easy loading and unloading of the datasets on your Palm.

The PalmEFIS Moving Map operations are:

• Sequence Through PalmEFIS Views
• Zooming and Scrolling
• Activate a Flight Plan
• Toggling Fix To/From Details and GPS Enable
• Airport Information
• Nearest Airport

Sequence Through PalmEFIS Views
PalmEFIS is built on an expandable platform. This allows new views or modules to be
integrated into PalmEFIS.

Pressing the Palm Schedule key cycles PalmEFIS through all
PalmEFIS modules or views that are installed on your Palm. For
example pressing the button could cycle the Attitude Indicator
view to the Moving Map view if both view are installed on your
Palm.

Zooming and Scrolling
Zooming and scrolling on the PalmEFIS Moving Map and Terrain Clearance is controlled by
the Palm’s Scroll key and the two keys just to its left and right, The Address List and the To
Do keys, or PalmEFIS operation keys. Zooming is the default operation that is assigned to
the Palm scroll keys. To change from zooming to scrolling first press one of the operation
keys to select the scroll direction and then press the scroll key to pan scroll the map.
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Repeatedly pressing the Address List key sequences the Moving
Map or Terrain Clearance through the zoom and scroll
operations, while pressing the To Do key sequences the
operations in the reverse order. The selected operation is
assigned to the Palm Scroll key. For example when the operation
is zooming the Palm Scroll key zooms the map in and out. When
the operation is sequenced to scrolling up and down the Palm
Scroll key scrolls the map up and down. An icon on the bottom
of the map displays the current Scroll key operation.

The operations sequence is:

1. Zoom in and out.

 2. Scroll up and down.

 3. Scroll up and down on a bottom left to top right diagonal.

 4. Scroll right and left.

 5. Scroll up and down on a top left to a bottom right diagonal.
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Activate a Flight Plan

Flight plans are created with the PalmEFIS Flight Plan Editor. After the flight plan is created
it is activated two different ways depending on which PalmEFIS view is active.

To activate a flight plan from the Moving Map and Terrain
Clearance views tap on the Palm dropdown menu button in the
Palm graffiti area after PalmEFIS is launched.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

With PalmOS 3.5 the Options menu will drop down. Select the
View menu item.

With PalmOS 3.5 the View Options popup list is displayed. A
tap on the Flight Director list item causes the Flight Plan
Options to be displayed.

With PalmOS 4 and above the Options menu will drop down.
Select the Flight Director menu item.

On the Flight Plan Options dialog, tap on the Name popup list
to see the available flight plans. Also note that the level of details
to show on flight plan fixes is controlled from this dialog.
Enabling or disabling the Distance To and Time To check boxes
tells the PalmEFIS Flight Director whether to only display the
fix label or also add the distance and time to the fix.

Selecting a flight plan in the Name popup list activates it. To
deactivate a flight plan select the first “---“ list item.
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To fly directly to a flight plan fix tap on the Direct To popup
list. A list will display showing all the flight plan fixes. Selecting
a fix from the list overrides the Flight Director’s auto leg
selection features and turns on the selected fix to fly directly to
it. The Direct To fix is turned off by selecting the first “---“ list
item.

Toggling Fix To/From Details and GPS Enable
The flight plan To/From fix details can be displayed in multiple formats. The first format
shows the To and From fixes along with their distance to it and the ETE. The other format
displays just the To fix with the heading and distance and the ETE.

To toggle the To/From fix details tap on the Calculator button
in the Palm silkscreen area.

If the GPS has been disabled because of a scrolling operation
the first tap enables the GPS and subsequent taps toggle the fix
details.

Airport Information

The PalmEFIS Moving Map defers the picking of airport information and displaying of
details airport information to the PalmEFIS Flight Director. The detailed airport information
includes communication frequencies, runway layout diagrams, services, and remarks. Airport
identifier picking is also available from the PalmEFIS Attitude, and Windometer views.

To see the airport details tap on an airport identifier with the
Palm stylist.

The Airport Information dialog is presented with the airport’s
communications frequencies.
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Tapping on the Runway button brings up the airport runway
diagram.

Tapping on the Support button display the services offered by
the airport.

Tapping on the Remarks button brings up the misc. airport
remarks. Press the OK push button when you are finished
viewing the airport information. When the OK button is tapped
the dialog disappears showing the moving map below.

Nearest Airport

The Nearest Airport feature is tied to the Palm hard Memo button. This button activates the
nearest airport search from the PalmEFIS Attitude, Windometer, Terrain Clearance views
along with the Moving Map view.

To toggle on or off the nearest airport search press the Palm
number 4 hardware button or the Memo button.
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The nearest airport button is a three-state button. With the first
press of the button the nearest airport is located and the Flight
Director will direct you to the airport it located. With the
Moving Map and Terrain Clearance views displayed the Flight
Director draws the nearest airport as a third flight plan leg. The
nearest airport identifier, heading, distance and ETE are
displayed in a box at the bottom of the moving map. The
background color on the box depends on whether the airport is
within gliding distance. Green is shown when gliding is an
option and red when the airport is too far.

The second press of the nearest airport button displays the
Airport Information dialog so that communications frequencies
for the airport can be entered into your radios.

The third press of the nearest airport button toggles the feature
off. If the nearest airport feature is left on the airport database
will be rescanned every few seconds to see if there is a nearer
airport. When a nearer airport is located it is displayed as the
nearest airport.
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8. PalmEFIS Windometer
PalmEFIS Windometer is PalmEFIS without an attitude. PalmEFIS Windometer has all the
speed, altitude, and heading capabilities of PalmEFIS but
focuses in on wind detection as its primary feature. While
PalmEFIS is geared more towards the IFR pilot that wants one
more redundancy or crosscheck, PalmEFIS Windometer is
directed towards the VFR pilot that wants to see the one thing
that they can't on that severe clear day. The wind! Now the wind
can be monitored during that burger run and as you arrive at the
burger stop you will already know that weather advisory that no
one seems to want to tell you about. Its OK! They're eating, and
soon you will be too. So now when you have the PalmEFIS
Windometer and you hear another pilot pleading for the wind information you can tell them
"its 260 at 12, but you would already know that if you too had the PalmEFIS Windometer."

Features
PalmEFIS Windometer focuses on the wind direction and speed, and the effect that the wind
has on the aircraft. Yet it still has the Heads Up display style where the aircraft speed is on
the left edge of the display, the aircraft direction is on top, with the current altitude
displayed on the right edge. Front and center on the PalmEFIS Windometer display are the
direct wind effects on your aircraft. This will graphically display the wind direction with
respect to your aircraft direction along with the current wind speed. PalmEFIS Windometer
works with statically entered wind speeds and directions or it can automatically determine
the wind components. The rest of the PalmEFIS Windometer functionality could be thought
of as a visual flight calculator where you can switch between Ground Speed, True Airspeed,
Indicated Airspeed, Magnetic Heading, True Course, Indicated Altitude or Density Altitude.
Except the difference is that the PalmEFIS Windometer is a flight computer that constantly
updates itself based on the current flight conditions.

Aircraft Speed

The aircraft speed is configurable to display Ground Speed, True Airspeed, or Indicated
Airspeed. The speed could also be set to use knots or mph units.

Compass

The compass shows either the True Course or Magnetic Heading.

Altimeter

The altimeter displays True Altitude or uses the outside air temperature, atmospheric
pressure and current altitude to determine and display the Density Altitude.
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Wind Direction and Speed Detection

PalmEFIS can work with statically entered wind speeds and directions or it can automatically
determine the wind conditions from the wind effects on your flight profile.

Head Wind and Cross Wind Components

To assist a pilot with their landing or headwind decisions PalmEFIS breaks the wind
conditions into their head and crosswind components and displays them as an overlay on the
Attitude Indicator view.

Speed, Heading and Altitude Bugs

The aircraft speed indicator, compass and altimeter all support bugs to mark the targeted
speed, heading and altitude.

Setup Options
Setting the PalmEFIS Windometer options allows the pilot to configure it to their preferences
or to use it in the same way as a flight calculator. The PalmEFIS Windometer options are:

• Set Bugs
• Select True or Density Altitude
• Select Indicated or True Airspeed or Ground Speed
• Select Track, True Course or Magnetic Heading
• Setting the Current Temperature and Altimeter
• Set Wind Speed and Direction

Set Bugs
PalmEFIS has Bugs for targeted trip speed, heading and altitude. The bugs are displayed as
black triangles on the speed, heading and altitude scales in a position that represents the bug
value.

To set a speed, heading or altitude bug tap on the Palm
dropdown menu button in the Palm graffiti area after starting
PalmEFIS.

The Palm dropdown menu bar will appear with the View menu
highlighted. Select the Set Bugs menu item.
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When the Set Bugs menu item is selected, PalmEFIS displays
the Bugs dialog. Here the current heading, altitude and speed
bugs are displayed. To change a bug setting drag Palm stylist
over the value to change and then enter a new value in the Palm
graffiti area.

Select True or Density Altitude
PalmEFIS can display the altitude as true altitude or density altitude. When density altitude is
selected the Altimeter scale and current altitude value adjust to display the density altitude.
For the density altitude to display correctly the current temperature must be set on the
Weather dialog. After selecting true or density altitude the PalmEFIS status bar will display
“TA” (true altitude) or “DA” (density altitude) depending on what was selected.

To select density or indicated altitude for PalmEFIS to display,
after starting the PalmEFIS, tap on the Palm dropdown menu
button in the Palm graffiti area.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Preferences menu
item.

The Preferences dialog will display once the Preferences menu
item is tapped. The true altitude/density altitude selection is near
the bottom of the dialog in the Altitude field. To select indicated
altitude tap on the TA box. Density altitude is selected by
tapping the DA box.

Select Indicated or True Airspeed or Ground Speed

The GPS data feed supplies the ground speed of the aircraft. It is possible with variations in
heading while the indicated airspeed of the aircraft is held constant to determine the true
airspeed of the aircraft. When the current temperature is entered into PalmEFIS it can then
determine the aircraft’s indicated airspeed. As such PalmEFIS can display any of the speed
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modes depending on pilot preferences or as a crosscheck of aircraft instrumentation. When
the pilot selects a ground speed, true airspeed or indicated airspeed, the speed mode is
displayed on the PalmEFIS status bar as the corresponding GS, TAS, or IAS.

To select indicated airspeed, true airspeed or ground speed for
PalmEFIS to display, tap on the Palm dropdown menu button in
the Palm graffiti area after launching PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

The Options menu will drop down. Select the Preferences menu
item.

The Preferences dialog will display once the Preferences menu
item is tapped. Find the Speed field in the Display section of the
dialog. Indicated Airspeed is selected by tapping on the IAS
box. To select True Airspeed tap the TAS box. Ground Speed
is selected by tapping on the GS box.

Select Magnetic Heading, True Course or Track

PalmEFIS can display the heading information with or without the magnetic variance for the
current location. The heading without the magnetic information is the true course as opposed
to using the magnetic variation to get the magnetic heading. The current heading mode is
displayed on the PalmEFIS status bar as TC for true course or MH for magnetic heading.

To select magnetic or true course heading for PalmEFIS to
display, tap on the Palm dropdown menu button in the Palm
graffiti area after launching PalmEFIS.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.
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The Options menu will drop down. Select the Preferences menu
item.

The Preferences dialog will display once the Preferences menu
item is tapped. In the Display section of the dialog is the
Heading field. The field could be set to magnetic heading (MH),
true course (TC) or Track (TRK). Tapping on the corresponding
box sets the heading mode.

Setting the Current Temperature and Altimeter

The current temperature and Altimeter values are used for density altitude and indicated
airspeed determination. The current temperature must be set before PalmEFIS can display
the density altitude or the indicated airspeed accurately.

To set the current temperature or altimeter values, tap on the
Palm dropdown menu button in the Palm graffiti area after
launching PalmEFIS.

With the View menu displayed select the Weather menu item.

Enter the current temperature in the Temperature field. The
temperature could be either Celsius or Fahrenheit. Set the
temperature units in the popup list at the end of the Temperature
field according to the units of the temperature value entered by
tapping on the down triangle and selecting C (Celsius) or F
(Fahrenheit).

Enter the current altimeter setting in the Altimeter field.
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Set Wind Speed and Direction

PalmEFIS supports automatic wind speed and direction detection or pilot entered wind speed
and direction. With the wind detection set in the automatic mode PalmEFIS determines the
wind speed and direction when the aircraft changes direction with a course difference of at
least 20 degrees. A new wind speed and directions is calculated after three consecutive
course changes. During the automatic wind detection process the indicated airspeed must be
constant. The pilot can at any time over-ride automatic wind detection and designate a wind
speed and direction. This is useful during the initial portion of the flight where ATIS
information is available and the automatic wind detection has not gathered enough
information to accurately predict the wind conditions.  

To tell PalmEFIS to automatically detect wind speed and
direction or to manually enter it, tap on the Palm dropdown
menu button in the Palm graffiti area after launching PalmEFIS.

With the View menu displayed select the Weather menu item.

The Weather dialog will appear. For automatic wind detection
check the Automatic check box. To over-ride the automatic
wind detection uncheck the Automatic check box and enter a
wind direction in the Direction field and wind speed in the Speed
field.

Operations
The Inner-Works

The PalmEFIS Wind Detection is determined by capturing the flight speed changes that
happen during a flight. The effects of power setting changes and climb/descent speeds
variations are filtered out to leave the effect caused by the wind. With the remaining wind
effects the wind speed and direction is determined. Three or more turns are necessary for
each wind sample where each turn must be greater then 25 degrees. The best wind detection
results are seen when the airspeed is held constant and the turns are greater then 45 degrees.

Best Practices

The best PalmEFIS Wind Detection results are seen when the airspeed is held constant and
where three consecutive the turns that are performed with a heading change between 25 then
45 degrees for each turn. Normal cruising, regardless of being on a flight plan, typically
yields good results. The best time to determine the wind conditions of a destination airport is
during the descent into the airport. Once the descent is stabilized make two shallow turns to
each side of the descent path followed by a turn back onto the descent path. If the altitude
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descent range is large follow this procedure several times to capture several wind detection
results. This will give you a wind change profile that could tell you what to expect in the way
of wind shear and other wind gust effects.

The Altimeter can display indicated or density altitudes. In the mountains in the summer
time it is useful to do a quick switch to density altitude to cross reference takeoff
performance before taking the active. While this may not get you to reach for the Pilot’s
Operating Manual, it may get you reaching for the mixture control to increase takeoff
performance.

The Compass displays a magnetic or true course heading. Both take into account magnetic
variation, but the magnetic heading also factors in the wind effects. The true course heading
is probably the more useful of the two, unless you only have a wet compass on board. The
PalmEFIS magnetic heading is a byproduct of the wind detection calculations. As such the
PalmEFIS magnetic heading and your wet compass may differ by a significant amount. This
is because at very slow speeds with moderate crosswinds the crab angle would have to be
quite large to maintain your current heading. If your wheels are still on the ground the odds
are that your aircraft is not crabbed. Therein arises the error between your compass and the
PalmEFIS headings. Letting the crab kick in after liftoff, PalmEFIS and your compass will
once more agree.

PalmEFIS can display Speed as ground speed, true airspeed or indicated airspeed. Of the
three the ground speed is the most useful unless your Pitot tube ices over. PalmEFIS gets the
ground speed directly from the GPS receiver, while the true airspeed and indicated airspeed
is a byproduct of the wind calculations.

Sequence Through PalmEFIS Views
PalmEFIS is built on an expandable platform. This allows new views or modules to be
integrated into PalmEFIS.

Pressing the Palm Schedule key cycles PalmEFIS through all
PalmEFIS modules or views that are installed on your Palm. For
example pressing the button could cycle the Attitude Indicator
view to the Moving Map view if both view are installed on your
Palm.
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9. PalmEFIS Flight Director
The PalmEFIS Flight Director is a navigator that uses a flight plan to take you from where
you are to where you want to go.

How many times have you looked at the Course Deviation
Indicator (CDI) and wondered does each dot represent two or
five miles? Or if the CDI needle is off to the left do I turn to the
right? With the PalmEFIS Flight Director navigation is no
longer a memorization test that must be coordinated with your
compass. You simply fly the arrow. The Flight Director arrow
always points directly to a fix. Align the arrow so that it is
straight up and you will go directly to the destination. If the
arrow is angled off to the right turn to the right until it once
more points up and you are again on course.

Have you ever wondered why you have to select an active flight
plan leg, or to reverse a flight plan? With the PalmEFIS Flight
Director you fly your aircraft and the Flight Director determines
the rest.

The PalmEFIS Flight Director overlays your flight plan
seamlessly on the PalmEFIS Attitude, Windometer, and
Moving Map views intelligently matching the display style to
the corresponding view.

Features
PalmEFIS Flight Director is built to lighten the workload of every pilot. It requires less work
to navigate and does it more intelligently. Once the flight plan is activated PalmEFIS Flight
director automatically and intelligently sequences the pilot through it in either direction
where the only control knob necessary is the aircraft yoke or stick. Simply put, now you can
have the navigation tools of the big iron, all in the palm of your hand.

The PalmEFIS Flight Director introduces several new navigation features, flying the arrow
and rubberbanding flight plan legs, and automatic flight plan traversal.

Automatic Flight Plan Leg Selection
Once a flight plan is activated the PalmEFIS Flight Director uses its automatic leg selection
feature to automatically determine the active flight plan leg. This means that you do not need
to select an active leg within your active flight plan nor do you need to reverse your flight
plan. That is because PalmEFIS Flight Director is intelligent, it knows the direction that you
are flying. When PalmEFIS Flight Director recognizes that you have deviated of course it
intelligently blends you back into the flight plan by skipping forward or backwards a leg
depending on which direction you are flying.
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Intelligent To/From Fix Selection
PalmEFIS Flight Director uses its intelligence of knowing the direction that you are flying to
select its To/From flight plan fixes. This removes the need to reverse a flight plan.

Direct To
At any time the pilot can override PalmEFIS Flight Director by selecting to fly directly to a
flight plan fix.

Fly the Arrow
PalmEFIS Flight Director introduces a new concept to navigation, flying the arrow to a flight
plan fix. Rather then looking at a line of dots and a needle that sits over the dots, PalmEFIS
Flight Director vectors you to a fix by providing an arrow that always points at the fix. Now
navigation is not a job of counting dots and multiplying by ten but turning your aircraft into
the arrow until it points straight up.

Rubberbanding Legs
As your flight progresses through a flight plan it constantly updates relative to your current
position to the active flight plan fixes. If you divert off course the Flight Director follows you
by angling the direction arrow towards the fixes or rubberbanding the flight plan legs to
your current position.

Identifier, Heading, Distance and ETE
The Flight Director displays the To/From fix’s identifier, distance and ETE of the flight
plan’s active leg. When the Attitude or Windometer views are active the To fix information
is displayed on top of the display and the From fix information on the bottom. If the Moving
Map view is active the To/From fix information is displayed on the bottom of the display.

Airport Information

Airport Information is always a tap away. The airport information provides a list of airport
communication frequencies, runway layout diagrams, services, and remarks.

Nearest Airport
At any time when the Nearest Airport button is pressed, the PalmEFIS Flight Director finds
the nearest airport and provides you with its communication frequencies, runway layout
diagrams, and then directs you to the airport. While PalmEFIS Flight Director directs you to
the nearest airport it constantly monitors and displays whether you are within gliding
distance of the airport. If you are within gliding distance of the nearest airport, the arrow of
segment is displayed as a green color. Otherwise it is red.
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Glide Distance
The Flight Director monitors the glide relationships between your current position and
altitude, and the altitude of the airports in your flight plan. When the Attitude or Windometer
view is displayed and you are flying the arrows, the arrows will be green if you are within
gliding distance and red otherwise.

Operations
The Inner-Works

The PalmEFIS Flight Director uses artificial intelligence to determine which flight plan leg
to activate and how to arrange the To/From fixes. It uses the same logic that you would use
for this determination. The factors that it uses are which flight plan fix is closest to the
current position? Which fix is most inline with the current heading? Is the current position
close enough to a flight plan fix to consider “rounding a corner” and heading to the next fix?
These questions are answered within the PalmEFIS Flight Director as rules where the two
dominate rules are which fix is the closest and which fix is most inline with the current
heading. These two rules play the role of picking the active flight plan leg and which fix is
the “To” fix within that leg.

Best Practices

Simplicity is central to the PalmEFIS Flight Director. Once the flight plan is activated you
“operate” the PalmEFIS Flight Director by flying your airplane. With your current position
the Flight Director selects a flight plan leg and arranges it’s To and From fixes based on your
current heading. If the Flight Director’s From fix is really your To fix or you want to turn
back it’s a simple matter of turning towards the From fix. This tells the Flight Director to
exchange the To and From fixes and arrange them according to your new heading.

The To and From airport identifiers that are displayed are pickable. Tapping on the displayed
airport identifier label pops up the Airport Information dialog. The Airport Information
dialog contains the airport’s communications frequencies, runway layout diagrams, services,
and remarks.

Flight plan rubberbanding legs has many benefits. The first is that you never have to find a
flight plan leg on the moving map. Is the leg to the left or right of your current position? This
disorientation is easy with north up maps. With rubberbanding legs the flight plan legs find
you. Determining on or off course is determined by whether the To and From legs create a
straight line. If you are off course there will be an angle between the two legs. The greater the
angle the farther that you are off course. To get back on course fly into the To fix or into the
angle. One of the nicest benefits of rubberbanding legs is to circumnavigate an airspace. The
airspace is avoided by flying an avoidance flight path until the To fix leg no longer intersects
the airspace and then turn into the To runner banding leg.

The Nearest Airport action has two benefits. The first is most obvious in that it finds that
nearest airport when an emergency arises, such as a restroom break. The second is a
byproduct of the fact that the Flight Director rescans for the nearest airport every couple of
seconds. When the Flight Director finds a nearer airport to your current position, it becomes
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the nearest airport. This allows you to track the nearest airport to your current position as you
progress towards your destination. This works this way whether a flight plan is active or not.

The PalmEFIS Flight Director operations are:

• Sequence Through PalmEFIS Views
• Activate a Flight Plan
• Airport Information
• Nearest Airport

Sequence Through PalmEFIS Views
PalmEFIS is built on an expandable platform. This allows new views or modules to be
integrated into PalmEFIS.

Pressing the Palm Schedule key cycles PalmEFIS through all
PalmEFIS modules or views that are installed on your Palm. For
example pressing the button could cycle the Attitude Indicator
view to the Moving Map view if both view are installed on your
Palm.

Activate a Flight Plan

Flight plans that are created with the PalmEFIS Flight Plan Editor are activated two different
ways depending on which PalmEFIS view is active.

Activate a flight plan from the PalmEFIS Attitude, Moving Map or Windometer views

To activate a flight plan from the Attitude or Windometer
views tap on the Palm dropdown menu button in the Palm
graffiti area after PalmEFIS is launched.

The menu bar is displayed at the top of the Palm display area.
Select the Options menu.

With PalmOS 3.5 the Options menu will drop down. Select the
View menu item.

With PalmOS 3.5 the View Options popup list is displayed. A
tap on the Flight Director list item causes the Flight Plan
Options to be displayed.
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With PalmOS 4 and above the Options menu will drop down.
Select the Flight Director menu item.

The Flight Plan Options dialog is displayed. Tap on the Name
popup list to see the available flight plans. Also note that the
level of details to show for a flight plan fix is controlled from
this dialog. Enabling or disabling the Distance To and Time To
check boxes tells the PalmEFIS Flight Director whether to only
display the fix label or also add the distance and time to the fix.

Selecting a flight plan in the Name popup list activates it. To
deactivate a flight plan select the first “---“ list item.

To fly directly to a flight plan fix tap on the Direct To popup
list. A list will display showing all the flight plan fixes. Selecting
a fix from the list overrides the Flight Director’s auto leg
selection features and turns on the selected fix to fly directly to
it. The Direct To fix is turned off by selecting the first “---“ list
item.

Nearest Airport

The Nearest Airport feature is tied to the Palm hard Memo button. This button activates the
nearest airport search from the PalmEFIS Attitude, Windometer, and Moving Map views.

To toggle on or off the nearest airport search press the Palm
number 4 hardware button or the Memo button.
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The nearest airport button is a three-state button. With the first
press of the button the nearest airport is located and the Flight
Director will direct you to the airport it located. If the Attitude
or Windometer views are active the Flight Director depicts the
nearest airport as an arrow that is shorter than the To/From
arrows. The nearest airport identifier, distance to, and ETE is
displayed in a box to the right of the From airport information.
The color of the nearest airport arrow and information box
depends on the glide performance of your aircraft. If you are
within gliding distance they will be green. The color is red
otherwise.

If the Moving Map view is displayed then the Flight Director
draws the nearest airport as a third flight plan leg. The nearest
airport identifier, heading, distance and ETE are displayed in a
box at the bottom of the moving map. The background color on
the box depends on whether the airport is within gliding
distance. Green is shown when gliding is an option and red when
the airport is too far.

The second press of the nearest airport button displays the
Airport Information dialog so that communications frequencies
for the airport can be entered into your radios.

The third press of the nearest airport button toggles the feature
off. If the nearest airport feature is left on the airport database
will be rescanned every few seconds to see if there is a nearer
airport. When a nearer airport is located it is displayed as the
nearest airport.

Airport Information

The PalmEFIS Flight Director supports airport identifier picking to see its detailed airport
information. The detailed airport information includes communication frequencies, runway
layout diagrams, services, and remarks. Airport identifier picking is available from the
PalmEFIS Attitude, Windometer, and Moving Map views.
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To pick an airport identifier to see
the airport details tap on the identifier
with the Palm stylist.

The Airport Information dialog is presented with the airports
communications frequencies.

Tapping on the Runway button brings up the airport runway
diagram.

Tapping on the Support button display the services offered by
the airport.
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Tapping on the Remarks button brings up the misc. airport
remarks. Press the OK push button when you are finished
viewing the airport information.
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10. PalmEFIS Flight Planning
PalmEFIS Flight Planning is full-featured flight planning in a
small package. It is built to work in the same manner as the
familiar flight plan worksheets that we have worked by hand. The
flight planning is tuned to support pilot’s decision-making
processes of the preflight. Yet the PalmEFIS Flight Planning is
easy enough that it will actually be used.

Simply put PalmEFIS Flight Planning makes flight planning fun
and no longer the chore.

Based on the entered Fixes, altitudes and percent power PalmEFIS Flight Planning populates
the rest of the flight plan. This includes:

• Magnetic Heading
• Distance
• ETE
• Fuel burn.
• Total distance
• Total time
• Total fuel used
• Fuel remaining

Features
PalmEFIS Flight Planning features a flight plan in a format that you are used to seeing. It
simply empowers the flight plan that you have been filling out by hand. But it also has the
features that you were wishing for as you sharpened your pencil and reached for your
calculator.

Full Featured Flight Plan Editor

PalmEFIS Flight Planning provides all the features that a pilot expects while building and
maintaining a flight plan. The Flight Plan Editor builds new flight plans, edits them, and
provides the ability to delete old flight plans. When editing a flight plan fixes could be
changed, inserted and deleted.

Finding Fixes
Finding fixes for a flight plan is simple and non-intrusive. If you know the airport identifier
enter it directly. Otherwise enter any part of the airport name or identifier and PalmEFIS
Flight Planning locates the fix for you.

Airport and Navaid Database

PalmEFIS Flight Planning uses the airport and navaid database of the PalmEFIS Dataset for
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the fix location as it builds a flight plan.

Heading, Distance, ETE and Fuel Usage

PalmEFIS Flight Planning has for its use a detailed airport database to locate fixes. This
means that by selecting a fix PalmEFIS Flight Planning automatically determines heading,
distance, ETE and fuel usage between two fixes. These values are then totaled to display the
trip’s distance, time and complete fuel burn.

Wind Effects
The wind effects are reflected in the PalmEFIS Flight Plan. The wind speed and direction is
taken from the PalmEFIS Weather dialog or the in-flight wind detection and back calculated
into the flight plan results.

What-if Analysis
With PalmEFIS Flight Planning knowing how your aircraft performs at a given power setting
and altitude you can play with the Percent Power and Altitude settings to see the effect they
have on the total time and fuel for the trip. Taxi fuel burns are also included in the trip totals
to yield the most accurate estimates.

Operations
The Inner-Works

Internally PalmEFIS Flight Planning interpolates your aircraft cruise performance chart in
two dimensions. It can work with altitudes and percent power settings that are not in your
chart. All this takes into account the maximum performance of your aircraft over an
altitude range. For example if you are targeting 10,000 feet as your cruise altitude and the
maximum power your aircraft can produce for that altitude is 70%, the flight plan percent
power will be trimmed back to 70% while letting the lower altitude legs achieve a higher
percent power rating.

The interpolation uses linear curve fitting and as such it induces a little error into the results.
The error effects are that the intermediate speeds will be determined to be a little slower than
reality and the fuel burns a little higher. Both are errors on the safe side.

Best Practices

At this stage of your flying you know how to create flight plans. With PalmEFIS Flight
Planning using a familiar flight plan layout you will find flight planning quite intuitive. The
what-if analysis is where the fun begins.

PalmEFIS Flight Planning uses four control parameters for its what-if analysis, Altitude,
Percent Power, and the Wind direction and speed. Changing any of these three parameters
effects the speed, ETE, and the fuel used. When working on long trips these three parameters
can be juggled to insure you have the proper fuel reserves when the destination is reached.
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The detected wind speed and direction is fed into the flight plan. This means that as the
winds aloft change during a flight, they have a real-time effect on the flight plan totals. So if
the destination is in question you can pull up the flight plan to check whether a fuel stop is
necessary or if a power change will do the trick.

Remember that the taxi fuel burn is subtracted from the remaining fuel amount that is
displayed on the flight plan.

The PalmEFIS Flight Planning operations are:

• Accessing the Flight Plan Editor
• Creating Flight Plans
• Editing Flight Plans
• Deleting Flight Plans

Accessing the Flight Plan Editor

Flight plans are created, edited and deleted with the PalmEFIS Flight Plan Editor. The Flight
Plan Editor is also where what-if analysis is performed on an existing flight plan.

It should be noted that PalmEFIS Flight Planning generates the flight plan names. It uses the
first and last fixes of the flight plan as the name.

Pressing the Palm Search silkscreen button accesses the Flight
Plan Editor.

When the Flight Plan Editor dialog appears it is ready to create a
new flight plan. If you want to edit or perform what-if analysis
on an existing flight plan tap on the Name popup list.

Previously created flight plans are listed to select.
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The selecting of a flight plan populates it into the Flight Plan
Editor, ready for your next step.

Creating Flight Plans

Flight plans are created with the Flight Plan Editor.

The editor initially loads it defaults to an empty flight plan form
that is ready to create a flight plan. If the Flight Plan Editor is
populated with a flight plan press the New push button at the
bottom of the dialog. This clears the editor and readies it for
entering a new flight plan.

The first step is to enter a new fix. This is done by tapping on the
first fix cell with the Palm stylist.

Tapping on the fix cell opens the Find Fix dialog. If you already
know the airport identifier enter it in the Fix field and press the
OK push button.

If you are unsure of the airport identifier enter any part of the
airports name or identifier and press the Find push button.

The first 10 fixes that match your entry are listed. From the list
select your airport and press the OK push button.

It is possible to enter custom fixes or waypoints into your flight
plan by tapping on the Airport popup list and selecting the
Waypoint list item. Fill in the prompted fix name and its latitude
and longitude coordinates.
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The entered fix is populated in the Flight Plan Editor. As two or
more fixes are entered into the flight plan the magnetic heading,
distance, ETE and fuel used fields are automatically populated
and totals are updated.

Editing Flight Plans

Flight plan editing allows you to add or insert fixes, remove fixes, set cruise altitudes, change
the starting fuel amount, and change the percent power for the flight.

The first step to editing a flight plan is to load it into the Flight
Plan Editor. Tap on the Name popup list and select the flight
plan to edit.

Extending your flight plan is done by tapping on the first empty
fix cell at the bottom of you flight plan.

The Find Fix dialog is displayed and you can select a fix just as
when you were creating the flight plan.
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Editing, inserting or deleting fixes done by tapping on an
existing fix. A popup menu is presented to select an operation.

Selecting to Edit the fix populates the fix in the Find Fix dialog.
The fix could then be changed to another fix.

If Insert Fix is selected the Find Fix dialog is presented to enter
a fix. The new fix is then inserted before the flight plan fix that
was tapped on.

Selecting Delete removes the fix from the flight plan. If all the
fixes are deleted from the flight plan the flight plan is deleted.

Tapping on an Altitude cell or Start Fuel trigger field presents
the Number Pad dialog. The Number Pad is a mini calculator
that facilitates operations such as adding 1000 feet to your
current altitude or 5 more usable gallons.

If the altitude is the flight plan’s first altitude all altitude fields
are populated with the new altitude. As altitude values are
changed the Flight Plan Editor recomputes the ETE and fuel
burn based on your aircraft cruise specifications.

Tapping on the % Power popup list and selecting a power
setting specifies the percent power for the flight plan. If a leg
altitude is too high to achieve the selected power rating the
power rating is truncated to the power that the aircraft produce at
the leg altitude.

After each edit operation has completed the complete flight plan
is recomputed.

Deleting Flight Plans

Flight plans are deleted from the PalmEFIS Flight Plan Editor. The delete flight plan is
permanently removed from you Palm Handheld.
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To delete a flight plan it must be loaded into the Flight Plan
Editor. Tap on the Name popup list and select the flight plan to
delete.

Once selected the flight plan is populated in the Flight Plan
Editor. Press the Delete push buttons on the bottom of the Editor
dialog.

Since the delete is permanent you will be prompted to make sure
that you did not hit the delete button by mistake. Press the Yes
push button to delete the flight plan.

The Flight Plan Editor is then returned to a new condition ready
to create a new flight plan.
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11. PalmEFIS Datasets
The PalmEFIS Flight Director, Flight Planning and Moving Map products use the PalmEFIS
Datasets. Within the Datasets are the airport information, navaids, airspace information and
topographical elevation data.

The PalmEFIS Datasets are built to provide quality data within a small memory footprint and
then it is subdivided into regions about the size of a sectional map. This allows a large
number of regions to be loaded onto a Palm without the need to reload new datasets.

The airport information contains the following details:

• Airport identifier
• Type
• Elevation
• Runway layout diagrams
• Communication frequencies
• Services

The navaid information contains the following details:

• Navaid identifier
• Type
• Elevation
• Communication frequencies

The airspace information contains the following details:

• Type
• Minimum elevation
• Maximum elevation
• Shape data

The topographical data contains the following details:

• Coordinates
• Elevation contours

All PalmEFIS databases start with a “pedb” prefix. The PalmEFIS Datasets end with one of
the following postfixes:

• ARPT for airport and navaid information.
• BDRY for airspace information.
• DEM for topographical data.

Each region contains datasets with the three postfixes. Between the “pedb” prefix and the
postfix is the region name. The dataset naming convention caused all the datasets for a region
to be grouped together when viewing them on the Palm. This allows a region to be easily
removed if it is no longer needed or if memory on your Palm needs to be freed up.
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PalmEFIS Dataset Installation
The PalmEFIS Datasets are self-configuring. If PalmEFIS sees a PalmEFIS Dataset on the
PDA it uses it.

To install a PalmEFIS Dataset first go to the
www.HangarB17.com site and download the dataset(s).

Locate the downloaded dataset(s), The Windows Explorer is
very useful for this. They will be in a zip file. Expand the zip file
into the directory that they were downloaded.

Select all the files that end with a “pdb” extension. Using the
mouse right-click on the selected files. A popup menu will be
displayed with “Open” as the first menu item. Select the “Open”
menu item.

The selected “pdb” files are then opened into the Palm Install
Tool. They are now ready to be installed on your PDA with a
HotSync operation.

Pressing the HotSync button on the Palm cradle starts the
HotSync operation that will install the PalmEFIS software.

Removing PalmEFIS Datasets
The PalmEFIS Datasets are self-configuring. If PalmEFIS sees a PalmEFIS Dataset on the
PDA it uses it. Conversely if the PalmEFIS Dataset is removed it is no longer used.
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From any PalmOS category activate the dropdown menu.

Select the App menu’s Delete menu item.

From the Delete dialog select the PalmEFIS Dataset region that
you wish to remove. Notice that there are three “pedb” database
files per region. They are the airport, airspace and topographical
information. To remove a region select each of the three files,
pressing the Delete button between each selection.
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12. Legal
PalmEFIS is not to be used as a primary means of aircraft navigation and attitude control. It
is not FAA certified for VFR or IFR purposes. The intent of PalmEFIS is as an assisting tool
to the pilot’s primary flight instrumentation. Pilots using PalmEFIS assume all risk as to how
or when the tool is used.
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